[SOLVED] Volume sublet do not work as intended

Added by tasty minerals about 5 years ago

Ok, here I installed via sur "volume" sublet.
But it does not appear in the tray.

I though that a workaround for volume control via keyboard could be this

grab "W-S-Up", "amixer -q sset Master 5+"".

But it seems like not to work in subtle.rb, how can I make it work?


Replies (8)

RE: Volume sublet do not work as intended - Added by Christoph Kappel about 5 years ago

  1. You really need to start reading docs. http://subforge.org/ezfaq/show/subtle?faq_id=27
  2. Why are there two doublequotes at the end? Check the output of subtle on your tty.

RE: Volume sublet do not work as intended - Added by tasty minerals about 5 years ago

Sorry, I'm in a hurry, reading manuals is not always as rewarding as a straight up question)
yes, double quotes, but it still do not work with the command options.
thank you again

RE: Volume sublet do not work as intended - Added by Christoph Kappel about 5 years ago

Well, I posted an entry from the FAQ. ;)

My questions why are there two doublequotes at the end? And is there anything in the output of subtle on your tty?

RE: [SOLVED] Volume sublet do not work as intended - Added by tasty minerals about 5 years ago

I've removed the second quote, it's my mistake. Sorry, but how can I see subtle tty output?

RE: [SOLVED] Volume sublet do not work as intended - Added by tasty minerals about 5 years ago

startx > .xinitrc(exec subtle)

Ok, I rebooted, volume sublet works now, seems like I needed a reboot for the needed module to load up.

RE: [SOLVED] Volume sublet do not work as intended - Added by Christoph Kappel about 5 years ago

Normally you just need to load the module and restart or reload subtle.

When you use xinit/startx the errors appear on the same tty you used the command.

RE: [SOLVED] Volume sublet do not work as intended - Added by tasty minerals about 5 years ago

well, ok
I don't use any login manager, and boot WM's from promt, by default it should be F7 tty, I guess.
I updated so needed a restart, thats why volume sublet refused to work.

(1-8/8)