Some sublets don't install

Added by Phil Thompson about 5 years ago

Hi there,

I'm having some problems with some of the sublets, namely, notify and betternotify. When running 'sur install notify' it downloads but is not placed in the respective folders under ~/.local/share/subtle. I'm installing on a minimal Ubuntu 12.04 setup.

Any ideas?

Thanks.
Phil


Replies (8)

RE: Some sublets don't install - Added by Christoph Kappel about 5 years ago

Hey, sorry for the late reply. Still the same issue?

Are there any values set for the env variable $XDG_DATA_DIRS or $XDG_DATA_HOME?

RE: Some sublets don't install - Added by Phil Thompson about 5 years ago

No problem.

Yeah, neither of those were set so I tried setting them to the defaults defined by freedesktop.org but they still don't install.

RE: Some sublets don't install - Added by Christoph Kappel about 5 years ago

Hm, normally sur uses the default when the vars are unset. What exactly happens, when you install a sublet, can you post the output of sur?

RE: Some sublets don't install - Added by Phil Thompson about 5 years ago

Well, mpd, battery, wifi, clock and cpu all installed ok but when I do:

sur install notify

I get:

>>> Fetching sublet `notify-0.44' (100%)
>>> Updated local cache with 5 entries

As I had 5 already it means it didn't install. I've checked the .local/share/subtle sub folders and notify is not there.

RE: Some sublets don't install - Added by Christoph Kappel about 5 years ago

Hm, version of subtle? The notify sublet requires the ffi gem, is it installed?

RE: Some sublets don't install - Added by Phil Thompson about 5 years ago

subtle 0.10.3008 - The version that comes with Ubuntu 12.04.

FFI wasn't installed but that wouldn't stop the sublet being installed would it? Unless it does prereq checks.

Ooh could it be that rbenv is effecting it?

RE: Some sublets don't install - Added by Christoph Kappel about 5 years ago

Well, your package manager normally uses another ruby version than you in your rbenv and that might cause the issues, yes. I just wonder why sur fails to check if the gem is installed, normally it does that.

RE: Some sublets don't install - Added by Phil Thompson about 5 years ago

I removed the path to rbenv so I'm getting the system ruby (ruby 1.9.3p0). There are no gems installed for it. Does sur need anything? Are the sublets downloaded into a temp folder? Is there a log file I can check?

I take it this issue is specific to my setup? Notify installs for you? I guess I could grab the latest version of subtle and compile it but that might have to wait until I've got some more time.

Thanks for your help so far.

(1-8/8)