Bug #315

subtle does not compile on archlinux

Added by François-Xavier LdM 11 months ago. Updated 11 months ago.

Status: Unconfirmed Start date: 2015-01-06
Priority: High Due date:
Assignee: - % Done:

0%

Category: -
Target version: -
Votes: 0

Description

When compiling :

/usr/include/X11/Xft/Xft.h:39:22: fatal error: ft2build.h: No such file or directory
#include <ft2build.h>

Quickfix : add

-I/usr/include/freetype2

in the ccppath variable of the RakeFile.

The Xft library package 2.3.2-1 seams to be the problem, but since subtle didn't needed to be rebuild until new version of ruby 2.2.0-1, the problems was hidden.

Associated revisions

Revision 3244
Added by Christoph Kappel 11 months ago

Fixed #315: Added check for emtpy xft cflags (see https://bugs.ruby-lang.org/issues/10651)

History

Thanks for the report, unfortunately I don't have an arch machine here right now.

Can you please show me the output of pkg-config --libs --cflags xft?

Hello,

here is the result :
@
~$ pkg-config --libs --cflags xft

-I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -lXft
@

Do you compile subtle on your own or via pkgbuild?

When you do it on your own, did you try to re-run the build script and wipe the old cached config data? The output of pkgconfig looks fine for me tho.

I tried both,

It seams to be a ruby issue :
https://aur.archlinux.org/packages/subtle/
--> https://bugs.ruby-lang.org/issues/10651

Weird, let me fetch 2.2.0 and give it a spin.

  • Status changed from Confirmed to Fixed
  • % Done changed from 0 to 100

Applied in changeset 31e0a9716e58.

  • Status changed from Fixed to Unconfirmed
  • % Done changed from 100 to 0

I've added a check for this in r3244, please update your repo and give it a try.

No more compilation compilation issue !
Thank you for this fix (sadly, #316 does not allow me to use subtle for now :/ )

No problem, I am looking into #316 right now.

Also available in: Atom PDF